Выполнить горячие клавиши 1с 8.3 в коде. Лучшие IT-решения для бизнеса

💖 Нравится? Поделись с друзьями ссылкой

При написании, просмотре, редактировании кода, навигации по пунктам меню 1С значительно ускорить эти процессы позволяют определенные комбинации нажатия на клавиши, так называемые «Горячие клавиши». Сразу скажу, что перечень будет приведен неполный. Только те, которые я использую в своей работе. Поэтому нелишним будет после прочтения этой статьи обратиться к справке 1С, чтобы расширить этот перечень. Список будет разбит на соответствующие разделы в соответствии с функциональным назначением. В основном будут рассмотрены сочетания, применимые при работе в режиме конфигуратора 1С.

При указании сочетаний клавиш будут использоваться латинские символы, хотя при использовании переключать клавиатуру на английский язык конечно же не нужно. Итак приступим.

    Навигация

    F12 — если установить курсор на место вызова процедуры или функции, то с помощью этой клавиши можно перейти непосредственно к процедуре или функции;

    Ctrl + ] — позволяет из начала логической конструкции перейти в ее конец. Под логическими конструкциями понимаются: Если … КонецЕсли, Для … Цикл … КонецЦикла, Функция … КонецФункции, Процедура … КонецПроцедуры. То есть если курсор у нас спозиционирован на операторе «Если», то после применения данного сочетания, он спозиционируеься на операторе «КонецЕсли». Очень удобно в ситуациях, когда приходится анализировать большие блоки кода;

    Ctrl + [ — позволяет из конца логической конструкции переместиться в ее начало;

    Ctrl + T — при редактировании кода эта комбинация клавиш позволяет переместиться в дерево метаданных конфигурации и спозиционироваться на том объекте, чей код вы сейчас редактируете;

    Alt + F2 — Устанавливает метку на строчке кода (впоследствии можно перемещаться к этой метке). Отображается синим кружком с левой стороны строки. Имя метки не устанавливается. Возможен последовательный обход меток в рамках текущего окна кода;

    F2 — Переход к следующей метке по направлению «вперед» в текущем окне кода;

    Shift + F2 — Переход к следующей метке по направлению «назад» в текущем окне кода;

    Ctrl + F — поиск текста;

    F3 — найти следующий фрагмент текста;

    Shift + F3 — найти предыдущий фрагмент текста;

    Ctrl + Home — переместить курсор в начало текста;

    Ctrl + End — переместить курсор в конец текста;

    Home — переместить курсор в начало текущей строки;

    End — переместить курсор в конец текущей строки;

    Ctrl + «стрелка вправо» — переместить курсор на одно слово вправо;

    Ctrl + «стрелка влево» — переместить курсор на одно слово влево;

    Работа с окнами

    Alt + Enter — открыть окно свойств. Информация в окне отображается для того элемента который был выделен до нажатия клавиш. Например, это может быть объект конфигурации, ячейка табличного документа, и т.д.;

    Alt + Shift + Enter — открыть окно дополнительных свойств. Используется для просмотра дополнительных свойств объектов конфигурации;

    Shift + Ctrl + Т — открывает окно с шаблонами текста;

    Shift + Ctrl + Z — закрывает окно служебных сообщений;

    Редактирование текста

    Ctrl + / (на цифровой клавиатуре) — закомментировать выделенный блок текста;

    Shift + Ctrl + / (на цифровой клавиатуре) — раскомментировать выделенный блок текста;

    Ctrl + C — скопировать выделенный текст в буфер;

    Ctrl + V — вставить из буфера;

    Ctrl + C — вырезать выделенный текст в буфер;

    Выделение текста

    Ctrl + A — выделить все;

    Shift + Ctrl + Home — выделить текст начиная с текущей позиции курсора и до начала текста;

    Shift + Ctrl + End — выделить текст начиная с текущей позиции курсора и до конца текста;

    Shift + Home — выделить текст начиная с текущей позиции курсора и до начала строки;

    Shift + End — выделить текст начиная с текущей позиции курсора и до конца строки;

    Shift + Ctrl + «стрелка вправо» — выделить слово справа от курсора. Удерживая Shift и Ctrl и последовательно нажимая стрелку можно выделять сразу несколько слов;

    Shift + Ctrl + «стрелка влево» — выделить слово слева от курсора;

    Shift + «стрелка вниз» — выделить строку со смещением курсора на одну строчку вниз. Удобно использовать при выделении нескольких строк;

    Shift + «стрелка вверх» — выделить строку со смещением курсора на одну строчку вверх;

    Отладка

    F7 — обновить конфигурацию;

    F5 — обновляет конфигурацию, открывает новое окно в режиме предприятия и включает режим отладки открытого окна;

    Ctrl + F5 — открывает новое окно в режиме предприятия и включает режим отладки открытого окна без обновления конфигурации;

    F9 — устанавливает точку останова на текущей строке кода в конфигураторе;

    Alt + F9 — открывает окно со списком всех точек останова конфигурации. Из этого окна можно переместиться к любой из них;

    Ниже приведены сочетания клавиш, которые используются в процессе отладки после того как отработала точка останова

    Sift + F9 — открывает окно в котором можно посмотреть значение переменной или результат вычисления какой-либо функции. Переменную или функцию можно предварительно выделить;

    F11 — пошаговая отладка. При каждом нажатии выполняется одна строка кода;

    Shift + F11 — текущая процедура или функция выполняется до конца, происходит выход из нее и отладочный курсор устанавливается на строке следующей за той из которой эта процедура (функция) вызывалась;

    Shift + F10 — код выполняется до текущей позиции курсора;

    Обсуждение закрыто.

Горячие клавиши — это, наверное, лучшее решение для упрощения работы с приложениями посредством клавиатуры после слепого метода печати. Принцип действия горячих клавиш таков, что к одной клавише или их комбинации привязывается отдельное действие, которое выполняется сразу же, как только эта клавиша или комбинация будут нажаты. В современных операционных системах есть стандартные наборы таких клавиш, а различные приложения дополнительно содержат собственные комбинации. В зависимости от настроек, предусмотренных авторами программы, такие клавиши и комбинации могут назначаться разработчиками или устанавливаться самими пользователями в параметрах приложения.

Платформа «1С:Предприятие 8» тоже не стала исключением из этого правила и содержит множество горячих клавиш, преимущественно единых для конфигураций «1С:Бухгалтерия», «1С:Зарплата и управление персоналом», «1С:Управление торговлей», «1С:Розница» и других. Более того, даже если вы самостоятельно напишете под эту платформу собственную конфигурацию, эти клавиши будут работать и в ней. Я же для создания скриншотов воспользуюсь конфигурацией «1С:Розница», поскольку в настоящее время пишу о работе с ней и она находится, что называется, под рукой.

Чтобы наиболее полно оценить рациональность такого технического решения, давайте посмотрим, как со стороны выглядят приемы работы с использованием горячих клавиш, а также без их участия.

Предположим, пользователь не подозревает о существовании горячих клавиш или, что бывает чаще, не уделяет им должного внимания, считая чем-то ненужным или заумным. В этом случае даже самая простая операция требует не менее двух-трех кликов мышкой по элементам интерфейса приложения — переключение на другие строки форм, пункты меню, нажатия кнопок и так далее. При этом эти элементы далеко не всегда находятся в непосредственной близости друг к другу. То есть во время такой работы нужно еще интенсивно двигать мышкой, периодически отпуская ее, чтобы ввести с клавиатуры какую-то информацию, а затем снова взять мышку в руку и продолжить работу.

Если говорить об одной-двух операциях, то особой проблемы в этом нет. Но дело в том, что пользователям «1С» очень часто приходится проводить в день сотни таких операций. Особенно в «1С:Бугхалтерии» и торговых конфигурациях. Простой пример — занесение вручную новых списков товарных позиций, что случается достаточно часто. А теперь прикиньте, сколько времени в течение дня уходит на взятие-оставление мышки и вождение курсора по экрану. А если в течение месяца?

Пользователь, уверенно владеющий навыком работы с горячими клавишами, может выполнять в разы большие объемы работы, не особо при этом утруждаясь. Например, если работать мышкой, то для создания нового документа нужно взять мышку, навести ее на кнопку создания документа и нажать ее. Затем нужно бросить мышку, заполнить с клавиатуры документ, снова взять мышку в руку и сохранить или провести документ.

А продвинутый пользователь в это же время просто нажмет клавишу Insert, создающую новый документ, тут же его заполнит, поскольку ему не нужно метаться между мышкой и клавиатурой, а затем нажмет комбинацию Ctrl+S или Ctrl+Enter — и все. В промышленных масштабах экономия времени просто колоссальна!

Для достижения наилучших результатов неплохо еще владеть техникой слепой печати. В рамках этой статьи мы ее рассматривать не будем, но от себя хочу добавить, что я быстро освоил слепую печать на русском и английском языках благодаря клавиатурному тренажеру VerseQ, обзор которого можно прочесть по этой . Я упоминаю здесь данный тренажер вовсе не из рекламных побуждений, а действительно считаю его гораздо более эффективным, чем другие, даже более известные тренажеры.

Но не будем отклоняться от темы. Итак, мы уже знаем, что клавиша Insert служит для создания нового элемента. Причем слово «элемент» здесь используется в самом широком смысле. Это может быть новая позиция номенклатуры в списке, новое подключаемое оборудование вроде кассового аппарата или сканера штрихкодов либо же обычный документ — счет-фактура, акт приема-передачи и так далее.


Иногда бывает так, что нужно создать не отдельный объект, а группу таких объектов. В качестве примера можно привести список номенклатуры, в котором для каждого товара заводится отдельная категория, что позволяет логически структурировать данные.

Такая группа представляет собой что-то вроде папочки, куда можно добавлять другие группы и непосредственно сами товары. Чтобы создать такую группу, можно воспользоваться комбинацией Ctrl+F9.


Эта комбинация сработает только в том случае, если вы находитесь в разделе, который поддерживает создание групп. Например, если у вас открыто окно поступления товаров, то в нем данная комбинация ничего не даст — здесь не предусмотрено никаких групп. А вот кнопка Insert, как обычно, создаст новый элемент. В нашем случае — поступление товаров.

Для того чтобы открыть уже занесенный в базу данных элемент для правки или просмотра, нужно нажать кнопку F2. Это будет эквивалентно нажатию в интерфейсе программы кнопки с изображением зеленого карандаша.


В зависимости от типа открытого элемента количество строк в его форме различается и их может быть довольно много. Чтобы переключаться между ними без помощи мышки, можно воспользоваться кнопкой Tab и комбинацией Shift+Tab. Первая переведет вас на следующую строку, а вторая — на предыдущую.


Кнопка Del выполняет несколько функций. Прежде всего это стандартное удаление текста в режиме редактирования. Кроме того, с ее помощью можно помечать на удаление системные объекты и удалять элементы, которые разрешено удалять напрямую, без предварительной пометки.

Например, если говорить о конфигурации «1С:Розница», это могут быть штрихкоды, закрепленные за каким-то наименованием или отдельным набором характеристик какого-то товара. А вот сам товар или характеристику просто так удалить не получится — нужно сначала пометить их на удаление, а затем удалить с помощью специальной функции.

Каждый документ, за исключением пометки на удаление, может иметь три основных состояния: несохраненный, сохраненный и проведенный документ.

С несохраненным все понятно. Это документ, который вы только что создали и не сохранили, или же сохраненный ранее документ, в который вы внесли какие-то правки, но тоже не сохранили. О том, что правки не были сохранены, свидетельствуют символы звездочки в заголовке вкладки и в названии документа.


Давайте разберемся, что общего и в чем разница между просто сохраненным и проведенным документом. Прежде всего изменения сохраняются как при обычном сохранении, так и при проведении. Также при этом документу присваивается номер. Но при простом сохранении имеет место простая запись внесенной информации, не более того. Проведенный же документ формирует все необходимые проводки и начинает участвовать в учете.

В качестве примера можно привести ситуацию с оприходованием товаров. Вы создаете документ, заносите туда нужные товары и его приходуемое количество и сохраняете без проведения. Документу будет присвоен номер, и он появится в списке документов оприходования. Более того, он будет содержать сведения о приходуемых товарах, включая их наименования, количество, единицы учета, стоимость и общую сумму, но само оприходование пока еще не было проведено.

Если вы в этот момент попытаетесь списать такой товар, спишутся только те его единицы, которые были поставлены на учет ранее. Если же такой товар прежде не поступал на склад, то списать его у вас не получится вообще. Его просто нет. Документ был создан, но не проведен, поэтому в реестр не была занесена запись о поступлении товара на склад. Такой сохраненный документ можно открыть в любой момент и провести его.

Для того чтобы провести документ и закрыть его, используется комбинация Ctrl+Enter. Правда, иногда бывает нужно провести документ, не закрывая его. Например, чтобы сразу же создать на его основании другой. Для этого служит кнопка «Провести» в интерфейсе приложения. Если для нее и существует горячая кнопка, то мне об этом ничего не известно.


Комбинации клавиш Ctrl+C и Ctrl+V хорошо известны по многим приложениям. Это стандартные комбинации, позволяющие копировать куски текста в буфер обмена и вставлять их в другие места.

Но в конфигурациях платформы «1С:Предприятие 8» есть еще и очень удобная функция, позволяющая создавать новый элемент путем копирования старого. Это делается с помощью горячей клавиши F9.

Данный инструмент создает копию предыдущего, в которую в дальнейшем можно внести нужные правки. Это очень удобно, когда новый документ мало чем отличается от старого. Например, если вы делаете счет-фактуру для контрагента, с которым вы уже работали прежде, вам не обязательно забивать с нуля все реквизиты. Достаточно выделить один из старых документов и нажать F9. После этого вам останется заменить табличную часть или еще какие-то мелочи. В итоге, если табличная часть не очень большая, на все про все у вас уйдет несколько секунд.

Таким способом можно клонировать не только документы, но и вообще любые записи. Предположим, что у вас есть элемент номенклатуры, имеющий длинный перечень характеристик, отличающихся одним-двумя значениями. Конечно, можно выделить весь список, скопировать его, а затем вставлять в каждую новую позицию и менять. Но ведь куда проще сделать это нажатием одной-единственной кнопки, не так ли?


Кнопка F5 служит для обновления страницы. Это помогает, например, когда состояние открытого документа изменилось за счет движения документов в соседних окнах или на другом компьютере. Скажем, статус оплаты открытого заказа изменился, когда вы провели все необходимые документы, но так как сам заказ висел у вас открытым, информация на экране не обновилась. В таких случаях и помогает F5.

Комбинации Ctrl+F и Ctrl+Q служат для активации и отключения режима поиска, а клавиша F1 традиционно запускает справочную систему.

Итак, теперь вы знаете все основные горячие кнопки, используемые в работе с конфигурациями платформы «1С:Предприятие». Другое дело, как вы воспользуетесь этим знанием. Из многолетнего опыта работы системным администратором я знаю, что пользователям часто банально лень учить эти комбинации. Их отговорки однообразны: «Это слишком сложно», «Я не запомню», «Я буду долго искать эти кнопки» и так далее в том же духе.

На самом деле ничего сложного в этом нет. Да, первые день-два вы будете вспоминать комбинации. Но здесь можно ориентироваться на подсказки, которые появляются, когда вы наводите курсор мышки на кнопку функции, для которой предусмотрена комбинация горячих клавиш.


Что касается положения нужных кнопок на клавиатуре, то, во-первых, коль уж вы работаете за компьютером, вы просто обязаны знать, где что находится, а во-вторых, часто используемые кнопки вы изучите очень быстро и будете использовать их автоматически, что не раз сослужит вам добрую службу.

В нем говорилось о работе с комбинацией клавиш в конфигураторе, что ускоряет и облегчает работу 1С программиста.
Вовремя работы заметил как многие пользователи не знают или не хотят учиться использовать сочетания клавиш в 1С:Предприятие, а вить использование быстрых клавиш в 1С:Предприятие в разы ускоряет работу.

Данные сочетания клавиш актуальны для но многие из них будут работать и в старых версиях платформы.
Начнем как в справке 1С.

Глобальные действия

F1 – открывает «Справку», соответствующий тому режиму, в котором Вы сейчас работаете.
Shift + F1 – открывает «Содержание справки»
Shift + Alt + F1 – открывает «Индекс справки»
Alt + F1 – открывает «Поиск по справке»

Alt + Left – переход к предыдущей главе справки или веб-странице
Alt + Right – переход к следующей главе справки или веб-странице

Новые механизмы которые появились в «1С:Предприятия 8.2»: Ссылка, История и Избранное очень облегчают работу пользователя и делают интерфейс более дружелюбным.
Ctrl + F11 – получить ссылку
Shift + F11 – перейти по ссылке
Ctrl + D – добавить в «Избранное»
Ctrl + Shift + B – открыть «Избранное»
Ctrl + Shift + H – открыть «История»
Ctrl + Shift + Z – открыть / закрыть «Служебные сообщения»
Сочетания Ctrl + F2 – открывает встроенный «Калькулятор»

Общие действия

Следующие сочетания клавиш должен знать каждый пользователь «1С:Предприятия».

Del – удалить, пометить на удаление, снять пометку на удаление.
Ins – добавить

Ctrl + S – сохраняет активный документ
Ctrl + P – производит печать активного документа
Ctrl + Shift + P – производит печать на текущий принтер

Ctrl + C (Ctrl + Ins) – копировать в буфер обмена
Ctrl + X (Shift + Del) – вырезать в буфер обмена
Ctrl + V (Shift + Ins) – вставить из буфера обмена

Ctrl + A – выделить все

Намного удобней чем каждый раз нажимать мышкой
Ctrl + Z (Alt + BackSpace) – отмена последнего действия
Ctrl + Y (Shift + Alt + BackSpace) – вернуть отмененное действие

Ctrl + F – найти
F3 – найти следующий
Ctrl + H – заменить

Данные сочетания клавиш удобны при работе с справочниками
Ctrl + Num+ – развернуть группу (узел дерева) справочника или табличного документа
Ctrl + Num- – свернуть группу или узел дерева

Ctrl + PgDn (Ctrl + Alt + F) – перейти на следующую страницу
Ctrl + PgUp (Ctrl + Alt + B) – Перейти на предыдущую страницу

Данный механизм помогает при анализе информаций, работе с отчетами.
Shift + Num* – копировать в буфер обмена как число
Shift + Num+ – добавить к буферу обмена
Shift + Num- – вычесть из буфера обмена

Сочетания клавиш в окнах приложения

Еще пару горячих клавиш в режиме «1С:Предприятия», которые нужны чаще чем другие.
Alt+1 – переход в панель разделов
Alt+2 – переход в панель навигации
Alt+3 – переход в панель действий
Alt+4 – переход в панель навигации в режиме открытия окон «В закладках»
Alt+9 – переход в панель истории
Esc – переход в окно формы после перехода в панели по Alt
Ctrl + Shift + – скрыть/показать панели разделов, навигации и действий
Tab (Shift+Tab) – переход между панелями и окном формы (при этом из формы по Tab выйти нельзя)

Форма

Enter – выполняет действия кнопки по умолчанию, а также переход к следующему элементу формы
Ctrl + Enter – выполняет действие кнопки по умолчанию
Tab – перейти к следующему элементу формы
Shift + Tab – вернуться к предыдущему элементу формы
Esc – закрыть активное вспомогательное окно

Для рабочего стола
F6 – переход к следующей форме рабочего стола
Shift + F6 – переход к предыдущей форме рабочего стола

Работа с табличным документом

F2 – переключение режима редактирования/ввода в ячейке
Home – перейти в начало строки
End – перейти в конец строки
Ctrl + Home – перейти в начало текста
Ctrl + End – перейти в конец текста
F4 – выбор значения в ячейке
Shift+F4 – очистка значения в ячейке
Ctrl + Shift + F4 – открытие для детального просмотра объект выбираемый в поле ввода.

Управление окнами

Alt + F4 – закрыть активное свободное окно, модальный диалог или приложение
Ctrl + F4 – закрыть активное обычное окно
Shift + Esc – закрыть активное окно
Ctrl + Tab (Ctrl + F6) – активизировать следующее обычное окно
Ctrl + Shift + Tab (Ctrl + Shift + F6) – активизировать предыдущее обычное окно
Alt + Space – сочетания вызвать системное меню приложения или модального диалога
F10 – активизировать главное меню
Shift + F10 – вызвать контекстное меню
Alt + Space – вызвать системное меню
Esc – вернуть активность обычному окну
Alt + Shift + R – восстановить положение окна

Вот пожалуй и все, наиболее горячие клавиши встречаемые в режиме 1С:Предприятия я указал. Кто хочет просмотреть более детальный обзор пусть посмотрит в 1С справке.

Заходим в
Содержание справки (Shift + F1) — 1С:Предприятие — Сочетания клавиш (1С:Предприятие).

Чтобы данные сочетания клавиш легче заполнить их лучше распечатать и держать перед собой на первом этапе, а когда Сочетания клавиш (1С:Предприятие) врежутся в память бумажки можно будет выкинуть.

Спасибо за внимание.

Пожалуйста, оставляйте комментарии к данной статьи, мне важно ваше мнение.

P.S. пародия на Бульдог Харламова

Рассказать друзьям